problem with “Primary Home” feature

My plan is to sell existing house, then rent, in 2028. In ESP program, in Primary Home, Current Home tab, entered market value, prop. tax, insurance, etc. (no mortgage, so all zeroes). In First Change of Home tab, checked box “Check here if plant to change home” and entered year, $ amounts for rent and other expenses in “Rental of New Home” boxes (leaving all zeros in “Purchase New Home” boxes).
In “Inputs and Assumptions” section of the created report, all inputted info shows correctly in "Current Housing/First Change in Housing" text pages but in “Suggestions” section, in “Total Spending” chart, in “Housing Expenditures” column, expenditures stay at current levels through all years until showing sale of house in 2041, year before spouse's death.
In “Details” section of the report, in “Housing” chart, shows continued prop. taxes, insurance, etc., through all future years, and nothing (zeroes) in “Rent and Rental” for all years, as if no change to rental. Similarly, in joint and individual “Estate” charts, shows “Housing Equity” for all future years, even after the year of Change of Home to rental, as if never sold/no switch to rental housing.
Why doesn't "the program" make the appropriate changes to reflect selling house, beginning renting in 2028?


dan royer's picture

I can't replicate such a problem here, and haven't heard of the housing report changes not sticking as you describe. Obviously, I suppose, after making those changes you create a new report? Make sure you are not calling up or looking at an old report.

You could create a support ticket and upload your database and I could take a look.


Thanks for your response. Yes, am creating and reviewing "new report(s)" as I revise inputs. Am using the new 2.36.3 version of ESPPlus. I have deleted "old" reports as I revise inputs over the years, so while no report available, am quite certain this was not a problem in the past (been using ESPl for 9 years). I will submit a support ticket; appreciate your review.

dan royer's picture

I responded to your ticket. It seems there might be a bug related to contingent planning. We're checking on that.